Difference between revisions of "Category:Installation"

From EPrints Documentation
Jump to: navigation, search
m
Line 36: Line 36:
 
| Ubuntu 16.04 LTS
 
| Ubuntu 16.04 LTS
 
| Supported*
 
| Supported*
| Current deb for EPrints 3.3.15 on deb.eprints.org will not install due to missing dependencies. http://files.eprints.org/1712/ contains a modified 3.3.15 deb package that fixes this issue and deals with the issue of segmentation faults when using Apache MPM Event module.  This is caused by LibXSLT.so that is installed as part of another dependency (libxml-libxslt-perl) that should also not be required.  Unit tests against this deb only report minor issues due to known (and now fixed) issues in the EPrints source code.  EPrints 3.3.16 deb (on deb.eprints.org) will have these updates to dependenices
+
| Current deb for EPrints 3.3.15 on deb.eprints.org will not install due to missing dependencies. http://files.eprints.org/1712/ contains a modified 3.3.15 deb package that fixes this issue and deals with the issue of segmentation faults when using Apache MPM Event module.  This is caused by LibXSLT.so that is installed as part of another dependency (libxml-libxslt-perl) that should also not be required.  Unit tests against this deb only report minor issues due to known (and now fixed) issues in the EPrints source code.  EPrints 3.3.16 deb (on deb.eprints.org) will have these updates to dependencies.
 
|-
 
|-
 
| Ubuntu 14.04 LTS
 
| Ubuntu 14.04 LTS

Revision as of 09:14, 1 September 2017

The default installation of EPrints is on a stand-alone linux system, but this is not the only way EPrints can (and has) been installed.

The EPrints team currently recommends installing EPrints in one of the following ways:


Here are some other ways:

This catagory contains a range of other sets of instructions for different operating systems and versions of EPrints. Most of them are not supported but may still work. For free support and discussion about EPrints you can sign up to the EP-Tech here: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech.

If you want to write Installation instructions for a system other than those listed here please do. Remember to tag the page with [[Category:Installation]] so that appears in this list.

If you use one of the installation guides below and it doesnt work edit the page to say what went wrong and how you fixed it. This will help others (and probably your future self) tackle these problems in future. Here you can register for an eprints.org account to edit the wiki.

Distribution Notes

Known issues and gotchas on various Linux distributions

Distibution Support Notes
Centos 7 Supported No known issues. EPrints Services test builds against this release [1].
Ubuntu 16.04 LTS Supported* Current deb for EPrints 3.3.15 on deb.eprints.org will not install due to missing dependencies. http://files.eprints.org/1712/ contains a modified 3.3.15 deb package that fixes this issue and deals with the issue of segmentation faults when using Apache MPM Event module. This is caused by LibXSLT.so that is installed as part of another dependency (libxml-libxslt-perl) that should also not be required. Unit tests against this deb only report minor issues due to known (and now fixed) issues in the EPrints source code. EPrints 3.3.16 deb (on deb.eprints.org) will have these updates to dependencies.
Ubuntu 14.04 LTS Supported No known issues. EPrints Services test builds against this release [2].

Subcategories

This category has the following 2 subcategories, out of 2 total.