Difference between revisions of "Category:Installation"

From EPrints Documentation
Jump to: navigation, search
m
Line 3: Line 3:
 
'''The EPrints team currently recommends installing EPrints in one of the following ways:'''
 
'''The EPrints team currently recommends installing EPrints in one of the following ways:'''
  
* '''[[Installing EPrints 3 via apt (Debian/Ubuntu)]]'''
+
* '''[[Installing EPrints on Debian/Ubuntu]]'''
* '''[[Installing_EPrints_3_on_RedHat_Enterprise_5|Installing using yum on RedHat Enterprise 5 or Fedora]]'''
+
* '''[[Installing EPrints on_RHEL/Fedora/CentOS]]'''
 
* '''[[Installation|Installing from source]]'''
 
* '''[[Installation|Installing from source]]'''
 
 
  
 
Here are some other ways:
 
Here are some other ways:
Line 14: Line 12:
 
* [[How to set up EPrints on virtual directories other than root|Hosted on virtual directories other than root]] - sharing with other Web applications on the same server
 
* [[How to set up EPrints on virtual directories other than root|Hosted on virtual directories other than root]] - sharing with other Web applications on the same server
  
This catagory contains a range of other sets of instructions for different operating systems and versions of EPrints. Most of them are not supported but may still work. {{EPrintsTech}}
+
This category contains a range of other sets of instructions for different operating systems and versions of EPrints. Most of them are not supported but may still work. {{EPrintsTech}}
  
 
If you want to write Installation instructions for a system other than those listed here please do. Remember to tag the page with <nowiki>[[Category:Installation]]</nowiki> so that appears in this list.  
 
If you want to write Installation instructions for a system other than those listed here please do. Remember to tag the page with <nowiki>[[Category:Installation]]</nowiki> so that appears in this list.  
Line 35: Line 33:
 
|-
 
|-
 
| Ubuntu 16.04 LTS
 
| Ubuntu 16.04 LTS
| Supported*
+
| Supported
| Current deb for EPrints 3.3.15 on deb.eprints.org will not install due to missing dependencies (for Ubuntu 16.04 onwards only). Please us the modified deb available at http://files.eprints.org/1712/.  Future versions of the eprints deb on deb.eprints.org will have this updated dependencies list.
+
| Some minor issues. See [[EPrints on Ubuntu 16.04]].
 
|-
 
|-
 
| Ubuntu 14.04 LTS
 
| Ubuntu 14.04 LTS

Revision as of 10:19, 5 September 2017

The default installation of EPrints is on a stand-alone linux system, but this is not the only way EPrints can (and has) been installed.

The EPrints team currently recommends installing EPrints in one of the following ways:

Here are some other ways:

This category contains a range of other sets of instructions for different operating systems and versions of EPrints. Most of them are not supported but may still work. For free support and discussion about EPrints you can sign up to the EP-Tech here: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech.

If you want to write Installation instructions for a system other than those listed here please do. Remember to tag the page with [[Category:Installation]] so that appears in this list.

If you use one of the installation guides below and it doesnt work edit the page to say what went wrong and how you fixed it. This will help others (and probably your future self) tackle these problems in future. Here you can register for an eprints.org account to edit the wiki.

Distribution Notes

Known issues and gotchas on various Linux distributions

Distibution Support Notes
Centos 7 Supported No known issues. EPrints Services test builds against this release [1].
Ubuntu 16.04 LTS Supported Some minor issues. See EPrints on Ubuntu 16.04.
Ubuntu 14.04 LTS Supported No known issues. EPrints Services test builds against this release [2].

Subcategories

This category has the following 2 subcategories, out of 2 total.