Difference between revisions of "Installing EPrints 3 via Redhat RPM"

From EPrints Documentation
Redirect page
Jump to: navigation, search
 
 
(4 intermediate revisions by 3 users not shown)
Line 1: Line 1:
Currently supported: RedHat Enterprise 4 32bit.
+
#REDIRECT [[Installing EPrints 3 on RedHat Enterprise 5]]
 
+
This also requires the DAG repository for some Perl dependencies.
+
 
+
===Adding the EPrints Yum Repository===
+
 
+
In <tt>/etc/sysconfig/rhn/sources</tt> add:
+
 
+
### Dag RPM Repository for Red Hat Enterprise Linux
+
yum dag http://apt.sw.be/redhat/el4/en/$ARCH/dag
+
 
+
### EPrints RPM Repository for Red Hat Enterprise Linux
+
yum eprints http://rpm.eprints.org/rhel4/
+
 
+
Import the DAG and EPrints distribution keys:
+
 
+
wget http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt
+
rpm --import RPM-GPG-KEY.dag.txt
+
rm RPM-GPG-KEY.dag.txt
+
 
+
wget http://rpm.eprints.org/RPM-GPG-KEY-tdb01r
+
rpm --import RPM-GPG-KEY-EPRINTS-2007
+
rm RPM-GPG-KEY-EPRINTS-2007
+
 
+
===Dependencies===
+
 
+
'''This will be redundant when there is a release EPrints 3, for now install dependencies and then use the [[Installing_EPrints_3_on_RedHat_Enterprise_4|release tarball]]'''
+
 
+
up2date perl-DBI perl-DBD-MySQL perl-Data-ShowTable \
+
perl-MIME-Lite perl-Unicode-String perl-Time-HiRes \
+
perl-XML-LibXML perl-XML-GDOME
+
 
+
===Install EPrints 3===
+
 
+
'''There isn't an RPM release of eprints3 available yet (in TODO for 3.01)'''
+
 
+
up2date eprints3
+
 
+
You can optionally install <tt>XML::GDOME</tt> using:
+
 
+
up2date perl-XML-GDOME
+
 
+
To switch to using GDOME modify <tt>/opt/eprints3/perl_lib/EPrints/SystemSettings.pm</tt>:
+
 
+
enable_libxml => 0
+

Latest revision as of 15:51, 29 April 2010