Installing EPrints 3 on Win32

From EPrints Documentation
Revision as of 15:45, 27 April 2010 by Tdb01r (Talk | contribs)

Jump to: navigation, search


Warning This feature requires EPrints version 3.2.1 or later

This page contains notes concerning installing version 3.2 on Win32-based platforms. There is still work to go on supporting EPrints on Win32.

Requirements

  • Microsoft Windows XP or later
  • Apache 2.0 or later
  • MySQL 5 or later
  • ModPerl 2.0 or later

Download EPrints Windows Installation Package (MSI)

Do not install this until ALL supporting software is in place and in the places outlined.

http://files.eprints.org/508/2/eprints%2D3.2.1%2Drc%2D1.msi

Supporting Software

Apache

Download and install Apache 2.2 + OpenSSL (if needed) from http://httpd.apache.org/download.cgi#apache22.

  • Change the installation directory to C:\Apache

MySQL

Download and install MySQL from http://dev.mysql.com/downloads/mysql/

  • Change default character set to Best support For Multilingualism

Perl

Download and install ActiveState Perl from http://www.activestate.com/activeperl/downloads/

ModPerl

Install mod_perl from the command prompt:

Other Modules

Install DBD::mysql from the command prompt:

  • ppm install DBD-mysql

Configuration

Edit the Apache configuration file C:\Apache\conf\httpd.conf and add below the last LoadModule line:

LoadFile C:/perl/bin/perl510.dll
LoadModule perl_module modules/mod_perl.so

And at the end of the file:

Include C:/eprints/cfg/apache.conf