Installing EPrints 3 on OS X

From EPrints Documentation
Revision as of 11:20, 6 September 2017 by Drn@ecs.soton.ac.uk (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Warning.png

Out of Date
The page has not been updated recently and is most likely out of date.

These instructions have not been updated since 2009 and are still considered a work in progress. It is unlikely they will work for the latest versions of Mac OS X.

http://www.eprints.org/documentation/handbook/osx.php

Notes:

  • Apache 2 should be installed from source along with mod_perl 2. The PerlHeaderParserHandler change is no longer necessary
  • All packages are now available as native OS X apps, so fink is not required.


N.B. This document is currently a work in progress - you should be able to get by with the installation instructions above for the time being.

Creating a user and group for EPrints

Note: This document assumes that you have used the same username, group name and home directory as listed in this section. If you choose to use different values (not recommended) then you will need to remember to use those at the appropriate places.

Downloading EPrints

EPrints can be downloaded from the releases page. You should choose the latest stable version, i.e. nothing marked with 'alpha', 'beta', 'release candidate' or 'RC', and download this to the home directory of the eprints user (/opt/eprints3).

Prerequisites

Important: All applications and Perl modules should be installed as the root user.

Applications

General application prerequisites for EPrints include:

  • Apache Web Server 2 (preferably 2.2.x)
  • MySQL (preferably 5.0 or later - it is possible (but not recommended) to use MySQL 4)
  • PHP (preferably 5.0 or later)
  • mod_perl 2

You can either install these packages individually from source or using a package management utility such as fink (highly recommended), or you can install a software package which includes all of these applications, such as xampp.

You will also need the following applications installed in order to install EPrints:

  • expat
  • imagemagick
  • tetex
  • tar
  • unzip
  • wget

All of these applications are now available as native OS X applications, and may already be installed on your system. However, you may find it easier to install them using fink.

Installing via fink (optional)

If you do not already have fink installed, you should download it from the Fink project website. Once fink is installed, you need to ensure that you are running the latest version using the following command:

fink selfupdate-rsync

N.B. The fink documentation will often tell you to simply use 'fink selfupdate', however this may not always work (especially if you are updating from an older version of fink on 10.4).

Once fink is installed and updated you can install all of the EPrints dependencies using the following commands:

fink install exoat
fink install imagemagick
fink install tetex
fink install tar
fink install unzip
fink install wget

Perl modules

There are a number of Perl modules which require installation before EPrints can be compiled. Some setup work is required beforehand, which can be accomplished by running the following commands:

cd /usr/include
h2ph */*
export EXPATLIBPATH=/sw/lib/
export EXPATINCPATH=/sw/include/
export PATH=$PATH:/usr/local/bin/

Once these commands have been executed, change to the directory where you extracted eprints and run the following command:

perl perlmodules.pl

This should download and install all of the required Perl modules and their dependencies. You may be prompted to configure CPAN at this stage if you have not already done so.

Credits

This document is based on the original Mac OS X installation guide, with updates for new versions of software, removal of instructions which are no longer necessary, and more detail on common problems which you may run into when installing EPrints on OS X.