Files/Validate Plugin

From EPrints Documentation
Revision as of 17:29, 10 September 2007 by WikiSysop (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This plugin will become part of EPrints 3.1, possibly even a 3.0.x

It allows you to specify validation errors in the workflow.

<component type="Validate"> <epc:if test="!is_set(creators) and !is_set(editors)"> <error><span class="ep_problem_field:creators">Creators</span> or <span class="ep_problem_field:editors">Editors</span> must be set.</error> <epc:if> <epc:if test="length(subjects) gt 5"> <error>You have selected <epc:print expr="length(subjects)" /> <span class="ep_problem_field:subjects">subjects</span>, but there is a maximum of 5 allowed.</error> <epc:if> </component>

Don't put the if's inside the (error) blocks as they will still cause a validation failure even if they contain no text.