Upgrading 3.2 to 3.3

From EPrints Documentation
Revision as of 05:54, 30 August 2018 by Kgoetz (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Install Procedure

1) Install the additional perl libraries (see below) unless you are installing via the debian/ubuntu package manager.

2) Install EPrints 3.3

3) Run epadmin upgrade on your archives

4) Update config files (see below)

Additional Perl Libraries

In order to improve search, we have decided to make use of external search libraries within EPrints. The easiest one to use and install is the Xapian search library with is available as a CPAN module. This is automatically installed on Debian/Ubuntu systems with EPrints 3.3. Other installs may require this to be installed manually along with the other libraries listed in the additional libraries section below:

It is highly recommended that the following pre-requisites be installed to enable full functionality in EPrints 3.3. These are all installed automatically on debian/ubuntu platforms.

  • libmime-types-perl (MIME::Types)
  • libxml-libxslt-perl (XML::XSLT)
  • libdigest-sha-perl (DIGEST::SHA)
  • libarchive-any-perl ~(Archive::Zip && Archive::Tar)
  • libsearch-xapian-perl (Search::Xapian)
  • unzip (system tool)

Update Config (Optional)

Many installs will have changed their templates so IGNORE this stage. However if you want to revert to the new default templates then please follow the instructions below:

1) Delete the archives built in template directories e.g.

  $ rm -fR archive_name/lib/lang/en/templates

2) Update the branding config file

  $ cp lib/defaultcfg/cfg.d/branding.pl archive_name/cfg/cfg.d

3) Restart Apache web server