Difference between revisions of "Issues with installing EPrints on RHEL / CentOS / Rocky 8"

From EPrints Documentation
Jump to: navigation, search
m (Drn@ecs.soton.ac.uk moved page Issues with installing EPrints on RHEL 8 to Issues with installing EPrints on RHEL / CentOS / Rocky 8: Linux OS versions are very similar so easier to only have one issues page for each.)
m
 
(3 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
==== elinks package is no longer available ====
 
==== elinks package is no longer available ====
The RPM package elinks is no longer available in RHEL 8 even with EPEL package repository.  elinks is probably no longer needed so if installing from source use the following YUM command line:
+
The RPM package '''elinks''' is no longer available in RHEL / CentOS / Rocky 8 even with EPEL package repository.  ''elinks'' is no longer needed so if installing from source use the following YUM command line:
  
 
  dnf install libxml2 libxslt httpd mod_perl perl-DBI perl-DBD-MySQL perl-IO-Socket-SSL perl-Time-HiRes \
 
  dnf install libxml2 libxslt httpd mod_perl perl-DBI perl-DBD-MySQL perl-IO-Socket-SSL perl-Time-HiRes \
Line 7: Line 7:
 
     gzip tar ImageMagick poppler-utils chkconfig unzip cpan
 
     gzip tar ImageMagick poppler-utils chkconfig unzip cpan
  
Alternatively, you can enable the '''codeready-builder''' repository, which still has elinks available:
+
Alternatively, for RHEL 8 you can enable the '''codeready-builder''' repository, which still has ''elinks'' available:
 
   
 
   
 
  subscription-manager repos --enable "codeready-builder-for-rhel-8-$(arch)-rpms"
 
  subscription-manager repos --enable "codeready-builder-for-rhel-8-$(arch)-rpms"
Line 15: Line 15:
 
  dnf config-manager --set-enabled powertools
 
  dnf config-manager --set-enabled powertools
  
==== Compatibility issues with XML::LibXLST ====
+
==== perl-IO-String package is no longer available ====
Sometimes the Perl module XML::LibXLST packaged in the perl-XML-LibXSLT package causes segmentation faults with the Apache httpd webserver.  Therefore, it may be better to install this Perl module using CPAN (as the root user):
+
The RPM package '''perl-IO-String''' is no longer available in RHEL / CentOS / Rocky 8 even with EPEL package repository. You can enable the '''codeready-builder''' repository, which still has ''perl-IO-String'' available:
 +
 
 +
subscription-manager repos --enable "codeready-builder-for-rhel-8-$(arch)-rpms"
 +
 
 +
If you are running CentOS 8 (or Rocky 8) you can similarly enable the '''powertools''' repository:
 +
 
 +
dnf config-manager --set-enabled powertools
 +
 
 +
==== Sub-dependency packages perl-MIME-Types and perl-Digest-SHA1 are no longer available ====
 +
'''perl-MIME-Lite''' package requires '''perl-MIME-Types''' package and ''' perl-Apache-DBI''' requires '''perl-Digest-SHA1''' package neither of which available on RHEL / CentOS / Rocky 8, even with EPEL repository enabled.  You can enable the '''codeready-builder''' repository, which still has these packahes available:
 +
 
 +
subscription-manager repos --enable "codeready-builder-for-rhel-8-$(arch)-rpms"
 +
 
 +
If you are running CentOS 8 (or Rocky 8) you can similarly enable the '''powertools''' repository:
 +
 
 +
dnf config-manager --set-enabled powertools
 +
 
 +
==== Compatibility issues with XML::LibXSLT ====
 +
Sometimes the Perl module XML::LibXSLT packaged in the perl-XML-LibXSLT package causes segmentation faults with the Apache httpd webserver.  Therefore, it may be better to install this Perl module using CPAN (as the root user):
  
 
  yum erase perl-XML-LibXSLT
 
  yum erase perl-XML-LibXSLT
 
  cpan XML::LibXSLT
 
  cpan XML::LibXSLT
 +
 +
If you have installed the '''eprints''' RPM either locally or though DNF (i.e. new YUM).  You will not be able to remove '''perl-XML-LibXSLT''' RPM without it forcing EPrints to be uninstalled.  Therefore, you should manually remove '''/usr/lib64/perl5/vendor_perl/auto/XML/LibXSLT/''' rather than uninstalling the package before installing it using CPAN.

Latest revision as of 14:01, 7 May 2021

elinks package is no longer available

The RPM package elinks is no longer available in RHEL / CentOS / Rocky 8 even with EPEL package repository. elinks is no longer needed so if installing from source use the following YUM command line:

dnf install libxml2 libxslt httpd mod_perl perl-DBI perl-DBD-MySQL perl-IO-Socket-SSL perl-Time-HiRes \
   perl-CGI perl-Digest-MD5 perl-Digest-SHA perl-JSON perl-XML-LibXML perl-XML-LibXSLT perl-XML-SAX \
   perl-MIME-Lite perl-Text-Unidecode perl-JSON perl-Unicode-Collate perl-Pod-LaTeX tetex-latex wget \
   gzip tar ImageMagick poppler-utils chkconfig unzip cpan

Alternatively, for RHEL 8 you can enable the codeready-builder repository, which still has elinks available:

subscription-manager repos --enable "codeready-builder-for-rhel-8-$(arch)-rpms"

If you are running CentOS 8 (or Rocky 8) you can similarly enable the powertools repository:

dnf config-manager --set-enabled powertools

perl-IO-String package is no longer available

The RPM package perl-IO-String is no longer available in RHEL / CentOS / Rocky 8 even with EPEL package repository. You can enable the codeready-builder repository, which still has perl-IO-String available:

subscription-manager repos --enable "codeready-builder-for-rhel-8-$(arch)-rpms"

If you are running CentOS 8 (or Rocky 8) you can similarly enable the powertools repository:

dnf config-manager --set-enabled powertools

Sub-dependency packages perl-MIME-Types and perl-Digest-SHA1 are no longer available

perl-MIME-Lite package requires perl-MIME-Types package and perl-Apache-DBI requires perl-Digest-SHA1 package neither of which available on RHEL / CentOS / Rocky 8, even with EPEL repository enabled. You can enable the codeready-builder repository, which still has these packahes available:

subscription-manager repos --enable "codeready-builder-for-rhel-8-$(arch)-rpms"

If you are running CentOS 8 (or Rocky 8) you can similarly enable the powertools repository:

dnf config-manager --set-enabled powertools

Compatibility issues with XML::LibXSLT

Sometimes the Perl module XML::LibXSLT packaged in the perl-XML-LibXSLT package causes segmentation faults with the Apache httpd webserver. Therefore, it may be better to install this Perl module using CPAN (as the root user):

yum erase perl-XML-LibXSLT
cpan XML::LibXSLT

If you have installed the eprints RPM either locally or though DNF (i.e. new YUM). You will not be able to remove perl-XML-LibXSLT RPM without it forcing EPrints to be uninstalled. Therefore, you should manually remove /usr/lib64/perl5/vendor_perl/auto/XML/LibXSLT/ rather than uninstalling the package before installing it using CPAN.