Difference between revisions of "Issues with Installing EPrints on Ubuntu 20.04"

From EPrints Documentation
Jump to: navigation, search
m
m (Previous issues)
 
Line 7: Line 7:
  
 
==== Previous issues ====
 
==== Previous issues ====
; ''xpdf'' Deb package no longer exists : This has been removed as a dependency since EPrints 3.4.3.
+
; ''xpdf'' Deb package no longer exists : This has been removed as a dependency since EPrints 3.4.3, as it is no longer specifically required by EPrints.
 
; MySQL deprecated syntax : <code>GRANT PRIVILEGES</code> command used by ''epadmin'' has been modified to avoid using deprecated syntax since EPrints 3.4.3.
 
; MySQL deprecated syntax : <code>GRANT PRIVILEGES</code> command used by ''epadmin'' has been modified to avoid using deprecated syntax since EPrints 3.4.3.

Latest revision as of 07:52, 30 April 2021

N.B. It is assumed that you are installing the latest version of 3.4. Earlier versions may have issues not listed here.

MySQL root user cannot be used

On Ubuntu 18.04 LTS rather than prompting you to set a password for MySQL server when installing this as a dependency, it just installs it without. However, this means on the root user can login to MySQL to add a database. As "epadmin create" runs at the eprints user, this will not be able to create a database for EPrints. The get round this as the root user connect to MySQL (just type "mysql" at the command line) and type the following two commands. You will want to set your own password (i.e. not 'changeme') , you may also want to restrict which databases the eprints user has control over. If you know the "Archive ID" you are going to use.

CREATE USER 'eprints'@'localhost' IDENTIFIED by 'changeme';
GRANT ALL PRIVILEGES ON *.* TO 'eprints'@'localhost' WITH GRANT OPTION;

Previous issues

xpdf Deb package no longer exists 
This has been removed as a dependency since EPrints 3.4.3, as it is no longer specifically required by EPrints.
MySQL deprecated syntax 
GRANT PRIVILEGES command used by epadmin has been modified to avoid using deprecated syntax since EPrints 3.4.3.