Issues with Installing EPrints on Ubuntu 16.04

From EPrints Documentation
Jump to: navigation, search

The current Debian package (Deb) for EPrints 3.3.15 on deb.eprints.org will not install due to missing dependencies for Ubuntu 16.04 onwards. You can use the modified Ddeb available at http://files.eprints.org/1712/. EPrints Services test builds against EPrints installed on Ubuntu 16.04 using this modified Deb. Future versions of the eprints Deb on deb.eprints.org will have this updated dependencies list.

The modified Deb for EPrints 3.3.15 removes the two following dependencies:

apache2-mpm-prefork: This no longer exists in Ubuntu 16.04 whereas in earlier versions you could choose between this and apache-mpm-event now the latter is the only choice.

libxml-libxslt-perl: Installing this with the version of Apache installed by Ubuntu 16.04 causes Apache to suffer a segmentation fault due to LibXSLT.so, which is installed as part of the Deb. This Deb is not critical for EPrints to function, so will not longer be listed as a dependency for future versions of the eprints Deb. The following functionality is not available by not installing the libxml-libxslt-perl Deb:

  • XSLT import.
  • XSLT export.
  • Use of .xsl citation style files.
  • Integration with Symplectic's Elements using the EPrints Repository Connector plugin.